Get in touch
Back
Resolved

Discrepancy in listening data for January 15-29 (Resolved)

Started 30 Jan at 08:19pm CET.

Studio
Created

We identified an issue affecting the listening data for January 15-29. The data has been corrected, and you will notice slightly higher numbers for this period now. We apologise for the discrepancy.

Posted 30 Jan at 08:19pm CET.