Get in touch
Back
Degraded

Service Window Wednesday, 27th November 2024, 16:00 - 17:00 CET

Started 26 Nov at 03:54pm CET, resolved 27 Nov at 04:08pm CET.

Studio
Resolved

Upgrade done.

Posted 27 Nov at 04:08pm CET.
Created

We are upgrading underlying technology. This upgrade is expected to cause only a couple of minutes of downtime.

Posted 26 Nov at 03:54pm CET.