Back to overview
Degraded

Longer than normal loading times

May 21 at 09:51am CEST
Affected services
Studio

Resolved
May 22 at 02:22pm CEST

We have identified the root cause of the issue and mitigated its impact on users.

Created
May 21 at 09:51am CEST

We are currently experiencing longer than normal loading times, which results in requests being automatically canceled. This, in turn, causes messages like "No data to display" and "Something went wrong" to appear.

We are investigating the issue and this takes priority from everything else.