Back to overview
Degraded
Statistics reports are currently missing data from Friday, May 12th
May 15 at 08:57am CEST
Affected services
Studio
Resolved
May 15 at 01:02pm CEST
The statistics from last week are now up to date.
Affected services
Created
May 15 at 08:57am CEST
We are working on solving the issue.
Affected services