Get in touch
Back
Degraded

Today's statistics update is delayed

Started 22 Nov at 01:04pm CET, resolved 22 Nov at 03:22pm CET.

Studio
Resolved

Issue solved!

Posted 22 Nov at 03:22pm CET.
Created

Today's statistics update is delayed. This will affect all listening data from monday 21/11. We are currently investigating the issue.

Posted 22 Nov at 01:04pm CET.